In breve
- CVE-2021-39187 è una vulnerabilità ALTO (CVSS 7.5) che riguarda parse-server (parseplatform), parse-server.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 1.8%, superiore al 78.7% delle vulnerabilità.
- Correzione: aggiornare a 4.10.3 o successiva.
Description
Impact
Parse Server crashes when if a query request contains an invalid value for the explain option. This is due to a bug in the MongoDB Node.js driver which throws an exception that Parse Server cannot catch.
Patches
Upgrade to Parse Server 4.10.3
NVD description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to version 4.10.3, Parse Server crashes when if a query request contains an invalid value for the `explain` option. This is due to a bug in the MongoDB Node.js driver which throws an exception that Parse Server cannot catch. There is a patch for this issue in version 4.10.3. No workarounds aside from upgrading are known to exist.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free