In breve
- CVE-2021-40110 è una vulnerabilità ALTO (CVSS 7.5) che riguarda org.apache.james:james-server, james (apache).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 3.0%, superiore al 87.2% delle vulnerabilità.
- Correzione: aggiornare a 3.6.1 o successiva.
Description
In Apache James, using Jazzer fuzzer, we identified that an IMAP user can craft IMAP LIST commands to orchestrate a Denial Of Service using a vulnerable Regular expression. This affected Apache James prior to 3.6.1 We recommend upgrading to Apache James 3.6.1 or higher , which enforce the use of RE2J regular expression engine to execute regex in linear time without back-tracking.
NVD description
In Apache James, using Jazzer fuzzer, we identified that an IMAP user can craft IMAP LIST commands to orchestrate a Denial Of Service using a vulnerable Regular expression. This affected Apache James prior to 3.6.1 We recommend upgrading to Apache James 3.6.1 or higher , which enforce the use of RE2J regular expression engine to execute regex in linear time without back-tracking.
Altre vulnerabilità di org.apache.james:james-server
Vedi tutto →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free