In breve
- CVE-2021-41121 è una vulnerabilità ALTO (CVSS 8.8) che riguarda vyper, vyper (vyperlang).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 1.1%, superiore al 65.0% delle vulnerabilità.
- Correzione: aggiornare a 0.3.0 o successiva.
| Package | Affected versions | Patched versions |
|---|
| vyper PyPI | < 0.3.0
| 0.3.0
|
| vyper | < 0.3.0
| 0.3.0
|
Description
Impact
When performing a function call inside a literal struct, there is a memory corruption issue that occurs because of an incorrect pointer to the the top of the stack.
Patches
0.3.0 / #2447
NVD description
Vyper is a Pythonic Smart Contract Language for the EVM. In affected versions when performing a function call inside a literal struct, there is a memory corruption issue that occurs because of an incorrect pointer to the the top of the stack. This issue has been resolved in version 0.3.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free