| Package | Affected versions | Patched versions |
|---|---|---|
| express openid connect | ≥ 2.3.0, < 2.5.2 | 2.5.2 |
| express-openid-connect | ≥ 2.3.0, < 2.5.2 | 2.5.2 |
Versions 2.3.0 up to and including 2.5.1 do not regenerate the session id and session cookie when user logs in. This behavior opens up the application to various session fixation vulnerabilities.
You are affected by this vulnerability if you are using express-openid-connect version 2.3.0 up to and including 2.5.1 and use a custom session store.
Upgrade to version >= 2.5.2.
The fix provided in patch will not affect your users.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free