In breve
- CVE-2021-41265 è una vulnerabilità ALTO (CVSS 8.8) che riguarda flask-appbuilder, flask-appbuilder (dpgaspar).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 1.3%, superiore al 70.8% delle vulnerabilità.
- Correzione: aggiornare a 3.3.4 o successiva.
Description
Impact
Improper authentication on the REST API. Allows for a malicious actor with a carefully crafted request to successfully authenticate and gain access to existing protected REST API endpoints. Only affects non database authentication types, and new REST API endpoints.
Patches
Upgrade to Flask-AppBuilder 3.3.4
For more information
If you have any questions or comments about this advisory:
NVD description
Flask-AppBuilder is a development framework built on top of Flask. Verions prior to 3.3.4 contain an improper authentication vulnerability in the REST API. The issue allows for a malicious actor with a carefully crafted request to successfully authenticate and gain access to existing protected REST API endpoints. This only affects non database authentication types and new REST API endpoints. Users should upgrade to Flask-AppBuilder 3.3.4 to receive a patch.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free