In breve
- CVE-2021-4286 è una vulnerabilità ALTO (CVSS 7.5) che riguarda srp, pysrp (pysrp project).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.77%, superiore al 55.7% delle vulnerabilità.
- Correzione: aggiornare a 1.0.17 o successiva.
| Package | Affected versions | Patched versions |
|---|
| srp PyPI | < 1.0.17
| 1.0.17
|
| pysrp | < 1.0.17
| 1.0.17
|
Description
A vulnerability, which was classified as problematic, has been found in cocagne pysrp up to 1.0.16. This issue affects the function calculate_x of the file srp/_ctsrp.py. The manipulation leads to information exposure through discrepancy. Upgrading to version 1.0.17 is able to address this issue. The name of the patch is dba52642f5e95d3da7af1780561213ee6053195f. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-216875.
NVD description
A vulnerability, which was classified as problematic, has been found in cocagne pysrp up to 1.0.16. This issue affects the function calculate_x of the file srp/_ctsrp.py. The manipulation leads to information exposure through discrepancy. Upgrading to version 1.0.17 is able to address this issue. The name of the patch is dba52642f5e95d3da7af1780561213ee6053195f. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-216875.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free