In breve
- CVE-2022-23500 è una vulnerabilità ALTO (CVSS 7.5) che riguarda typo3/cms, typo3/cms-core, typo3 (typo3).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.73%, superiore al 54.3% delle vulnerabilità.
- Correzione: aggiornare a 10.4.33, 11.5.20, 9.5.38 o successiva.
| Package | Affected versions | Patched versions |
|---|
| typo3/cms Packagist | ≥ 10.0.0, < 10.4.33≥ 11.0.0, < 11.5.20
| 10.4.3311.5.20
|
| typo3/cms-core Packagist | ≥ 10.0.0, < 10.4.33≥ 11.0.0, < 11.5.20≥ 9.0.0, < 9.5.38
| 10.4.3311.5.209.5.38
|
| typo3 | ≥ 10.0.0, < 10.4.33≥ 11.0.0, < 11.5.20≥ 9.0.0, < 9.5.38
| 10.4.3311.5.209.5.38
|
Description
Problem
Requesting invalid or non-existing resources via HTTP triggers the page error handler, which again could retrieve content to be shown as an error message from another page. This leads to a scenario in which the application is calling itself recursively - amplifying the impact of the initial attack until the limits of the web server are exceeded.
This vulnerability is very similar, but not identical, to the one described in TYPO3-CORE-SA-2021-005 (CVE-2021-21359).
Solution
Update to TYPO3 versions 9.5.38 ELTS, 10.4.33 or 11.5.20 that fix the problem described above.
References
NVD description
TYPO3 is an open source PHP based web content management system. In versions prior to 9.5.38, 10.4.33, 11.5.20, and 12.1.1, requesting invalid or non-existing resources via HTTP triggers the page error handler, which again could retrieve content to be shown as an error message from another page. This leads to a scenario in which the application is calling itself recursively - amplifying the impact of the initial attack until the limits of the web server are exceeded. This vulnerability is very similar, but not identical, to the one described in CVE-2021-21359. This issue is patched in versions 9.5.38 ELTS, 10.4.33, 11.5.20 or 12.1.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free