In breve
- CVE-2022-23514 è una vulnerabilità ALTO (CVSS 7.5) che riguarda loofah, loofah (loofah project).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 1.8%, superiore al 78.9% delle vulnerabilità.
- Correzione: aggiornare a 2.19.1 o successiva.
| Package | Affected versions | Patched versions |
|---|
| loofah RubyGems | < 2.19.1
| 2.19.1
|
| loofah | < 2.19.1
| 2.19.1
|
Description
Summary
Loofah < 2.19.1 contains an inefficient regular expression that is susceptible to excessive backtracking when attempting to sanitize certain SVG attributes. This may lead to a denial of service through CPU resource consumption.
Mitigation
Upgrade to Loofah >= 2.19.1.
Severity
The Loofah maintainers have evaluated this as High Severity 7.5 (CVSS3.1).
References
Credit
This vulnerability was responsibly reported by @ooooooo-q (https://github.com/ooooooo-q).
NVD description
Loofah is a general library for manipulating and transforming HTML/XML documents and fragments, built on top of Nokogiri. Loofah < 2.19.1 contains an inefficient regular expression that is susceptible to excessive backtracking when attempting to sanitize certain SVG attributes. This may lead to a denial of service through CPU resource consumption. This issue is patched in version 2.19.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free