In breve
- CVE-2022-23516 è una vulnerabilità ALTO (CVSS 7.5) che riguarda loofah, loofah (loofah project).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 1.2%, superiore al 67.4% delle vulnerabilità.
- Correzione: aggiornare a 2.19.1 o successiva.
| Package | Affected versions | Patched versions |
|---|
| loofah RubyGems | ≥ 2.2.0, < 2.19.1
| 2.19.1
|
| loofah | ≥ 2.2.0, < 2.19.1
| 2.19.1
|
Description
Summary
Loofah >= 2.2.0, < 2.19.1 uses recursion for sanitizing CDATA sections, making it susceptible to stack exhaustion and raising a SystemStackError exception. This may lead to a denial of service through CPU resource consumption.
Mitigation
Upgrade to Loofah >= 2.19.1.
Users who are unable to upgrade may be able to mitigate this vulnerability by limiting the length of the strings that are sanitized.
Severity
The Loofah maintainers have evaluated this as High Severity 7.5 (CVSS3.1).
References
NVD description
Loofah is a general library for manipulating and transforming HTML/XML documents and fragments, built on top of Nokogiri. Loofah >= 2.2.0, < 2.19.1 uses recursion for sanitizing CDATA sections, making it susceptible to stack exhaustion and raising a SystemStackError exception. This may lead to a denial of service through CPU resource consumption. This issue is patched in version 2.19.1. Users who are unable to upgrade may be able to mitigate this vulnerability by limiting the length of the strings that are sanitized.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free