In breve
- CVE-2022-23556 è una vulnerabilità ALTO (CVSS 7.5) che riguarda codeigniter4/framework, codeigniter (codeigniter).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.40%, superiore al 34.1% delle vulnerabilità.
- Correzione: aggiornare a 4.2.11 o successiva.
Description
Impact
This vulnerability may allow attackers to spoof their IP address when your server is behind a reverse proxy.
Patches
Upgrade to v4.2.11 or later, and configure Config\App::$proxyIPs.
Workarounds
Do not use $request->getIPAddress().
References
For more information
If you have any questions or comments about this advisory:
NVD description
CodeIgniter is a PHP full-stack web framework. This vulnerability may allow attackers to spoof their IP address when the server is behind a reverse proxy. This issue has been patched, please upgrade to version 4.2.11 or later, and configure `Config\App::$proxyIPs`. As a workaround, do not use `$request->getIPAddress()`.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free