In breve
- CVE-2022-24709 è una vulnerabilità MEDIO (CVSS 6.1) che riguarda awsui/components-react (amazon), @awsui/components-react.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.69%, superiore al 52.9% delle vulnerabilità.
- Correzione: aggiornare a 3.0.367 o successiva.
Description
Impact
Components could potentially allow cross-site scripting (XSS) in certain circumstances. These components could render content without adequate neutralization.
Patches
Fixed in 3.0.367.
NVD description
@awsui/components-react is the main AWS UI package which contains React components, with TypeScript definitions designed for user interface development. Multiple components in versions before 3.0.367 have been found to not properly neutralize user input and may allow for javascript injection. Users are advised to upgrade to version 3.0.367 or later. There are no known workarounds for this issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free