In breve
- CVE-2022-24710 è una vulnerabilità MEDIO (CVSS 5.4) che riguarda weblate, weblate (weblate).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.75%, superiore al 55.1% delle vulnerabilità.
- Correzione: aggiornare a 4.11 o successiva.
| Package | Affected versions | Patched versions |
|---|
| weblate PyPI | < 4.11
| 4.11
|
| weblate | < 4.11
| 4.11
|
Description
Impact
Due to improper neutralization, it was possible to perform cross-site scripting via crafted user and language names.
Patches
The issues were fixed in the 4.11 release. The following commits are addressing it:
- f6753a1a1c63fade6ad418fbda827c6750ab0bda
- 9e19a8414337692cc90da2a91c9af5420f2952f1
- 22d577b1f1e88665a88b4569380148030e0f8389
Workarounds
You can look for crafted user and language names to see if you were affected.
References
For more information
If you have any questions or comments about this advisory:
NVD description
Weblate is a copyleft software web-based continuous localization system. Versions prior to 4.11 do not properly neutralize user input used in user name and language fields. Due to this improper neutralization it is possible to perform cross-site scripting via these fields. The issues were fixed in the 4.11 release. Users unable to upgrade are advised to add their own neutralize logic.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free