In breve
- CVE-2022-24814 è una vulnerabilità MEDIO (CVSS 6.1) che riguarda directus (rangerstudio), directus.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 1.0%, superiore al 63.9% delle vulnerabilità.
- Correzione: aggiornare a 9.7.0 o successiva.
| Package | Affected versions | Patched versions |
|---|
| directus | < 9.7.0
| 9.7.0
|
| directus npm | < 9.7.0
| 9.7.0
|
Description
Impact
Unauthorized JavaScript can be executed by inserting an iframe into the rich text html interface that links to a file uploaded HTML file that loads another uploaded JS file in its script tag. This satisfies the regular content security policy header, which in turn allows the file to run any arbitrary JS.
Patches
This was resolved in https://github.com/directus/directus/pull/12020 which is released in 9.7.0
Workarounds
You can disable the live embed in the WYSIWYG by adding { "media_live_embeds": false } to the Options Overrides option of the Rich Text HTML interface.
References
https://github.com/directus/directus/pull/12020
For more information
If you have any questions or comments about this advisory:
NVD description
Directus is a real-time API and App dashboard for managing SQL database content. Prior to version 9.7.0, unauthorized JavaScript (JS) can be executed by inserting an iframe into the rich text html interface that links to a file uploaded HTML file that loads another uploaded JS file in its script tag. This satisfies the regular content security policy header, which in turn allows the file to run any arbitrary JS. This issue was resolved in version 9.7.0. As a workaround, disable the live embed in the what-you-see-is-what-you-get by adding `{ "media_live_embeds": false }` to the _Options Overrides_ option of the Rich Text HTML interface.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free