In breve
- CVE-2022-25769 è una vulnerabilità CRITICO (CVSS 9.1) che riguarda mautic/core, mautic (acquia).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.51%, superiore al 43.3% delle vulnerabilità.
- Correzione: aggiornare a 4.2.0, 3.3.5 o successiva.
| Package | Affected versions | Patched versions |
|---|
| mautic/core Packagist | ≥ 4.0.0, < 4.2.0< 3.3.5
| 4.2.03.3.5
|
| mautic | ≥ 4.0.0, < 4.2.0< 3.3.5
| 4.2.03.3.5
|
Description
Impact
the default .htaccess file has some restrictions in the access to PHP files to only allow specific PHP files to be executed in the root of the application.
This logic isn't correct, as the regex in the second FilesMatch only checks the filename, not the full path.
Patches
Please upgrade to 3.3.5 or 4.2.0
Workarounds
No
References
For more information
If you have any questions or comments about this advisory:
NVD description
ImpactThe default .htaccess file has some restrictions in the access to PHP files to only allow specific PHP files to be executed in the root of the application.
This logic isn't correct, as the regex in the second FilesMatch only checks the filename, not the full path.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free