| Package | Affected versions | Patched versions |
|---|---|---|
| npm | ≥ 7.9.0, < 8.11.0 | 8.11.0 |
| npm | ≥ 7.9.0, < 8.11.0 | 8.11.0 |
npm pack ignores root-level .gitignore & .npmignore file exclusion directives when run in a workspace or with a workspace flag (ie. --workspaces, --workspace=<name>). Anyone who has run npm pack or npm publish with workspaces, as of v7.9.0 & v7.13.0 respectively, may be affected and have published files into the npm registry they did not intend to include.
npm (v8.11.0 or greater), run: npm i -g npm@latestv16.15.1, v17.19.1 & v18.3.0 include the patched v8.11.0 version of npmnpm publish --dry-run or npm pack with an npm version >=7.9.0 & <8.11.0 inside the project's root directory using a workspace flag like: --workspaces or --workspace=<name> (ex. npm pack --workspace=foo)tar -tvf <package-on-disk> also works)npm deprecate <pkg>[@<version>] <message>)
3.3. Revoke or rotate any sensitive information (ex. passwords, tokens, secrets etc.) which might have been exposedRunning one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free