In breve
- CVE-2022-31015 è una vulnerabilità MEDIO (CVSS 5.9) che riguarda waitress, waitress (agendaless).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 1.5%, superiore al 74.2% delle vulnerabilità.
- Correzione: aggiornare a 2.1.2 o successiva.
| Package | Affected versions | Patched versions |
|---|
| waitress PyPI | ≥ 2.1.0, < 2.1.2
| 2.1.2
|
| waitress | ≥ 2.1.0, < 2.1.2
| 2.1.2
|
Description
Impact
Waitress may terminate early due to a thread closing a socket while the main thread is about to call select(). This will lead to the main thread raising an exception that is not handled and then causing the entire application to be killed.
Patches
This issue has been fixed in Waitress 2.1.2 by no longer allowing the WSGI thread to close the socket, instead it is always delegated to the main thread.
Workarounds
There is no work-around, however users using waitress behind a reverse proxy server are less likely to have issues if the reverse proxy always reads the full response.
For more information
If you have any questions or comments about this advisory:
NVD description
Waitress is a Web Server Gateway Interface server for Python 2 and 3. Waitress versions 2.1.0 and 2.1.1 may terminate early due to a thread closing a socket while the main thread is about to call select(). This will lead to the main thread raising an exception that is not handled and then causing the entire application to be killed. This issue has been fixed in Waitress 2.1.2 by no longer allowing the WSGI thread to close the socket. Instead, that is always delegated to the main thread. There is no work-around for this issue. However, users using waitress behind a reverse proxy server are less likely to have issues if the reverse proxy always reads the full response.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free