In breve
- CVE-2022-31026 è una vulnerabilità ALTO (CVSS 7.5) che riguarda trilogy, trilogy (trilogy project).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 1.1%, superiore al 65.7% delle vulnerabilità.
- Correzione: aggiornare a 2.1.1 o successiva.
| Package | Affected versions | Patched versions |
|---|
| trilogy RubyGems | < 2.1.1
| 2.1.1
|
| trilogy | < 2.1.1
| 2.1.1
|
Description
Impact
When authenticating, a malicious server could return a specially crafted authentication packet, causing the client to read and return up to 12 bytes of data from an uninitialized variable in stack memory.
Patches
Users of the trilogy gem should upgrade to version 2.1.1
Workarounds
This issue can be avoided by only connecting to trusted servers.
Acknowledgements
We would like to thank Sergei Volokitin for reporting this vulnerability
For more information
If you have any questions or comments about this advisory:
NVD description
Trilogy is a client library for MySQL. When authenticating, a malicious server could return a specially crafted authentication packet, causing the client to read and return up to 12 bytes of data from an uninitialized variable in stack memory. Users of the trilogy gem should upgrade to version 2.1.1 This issue can be avoided by only connecting to trusted servers.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free