In breve
- CVE-2022-31124 è una vulnerabilità MEDIO (CVSS 6.5) che riguarda openssh-key-parser, openssh key parser (openssh key parser project).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 1.3%, superiore al 71.3% delle vulnerabilità.
- Correzione: aggiornare a 0.0.6 o successiva.
Description
Impact
If a field of a key is shorter than it is declared to be, the parser raises an error with a message containing the raw field value. An attacker able to modify the declared length of a key's sensitive field can thus expose the raw value of that field.
Patches
Upgrade to version 0.0.6, which no longer includes the raw field value in the error message.
Workarounds
N/A
References
N/A
For more information
If you have any questions or comments about this advisory:
NVD description
openssh_key_parser is an open source Python package providing utilities to parse and pack OpenSSH private and public key files. In versions prior to 0.0.6 if a field of a key is shorter than it is declared to be, the parser raises an error with a message containing the raw field value. An attacker able to modify the declared length of a key's sensitive field can thus expose the raw value of that field. Users are advised to upgrade to version 0.0.6, which no longer includes the raw field value in the error message. There are no known workarounds for this issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free