In breve
- CVE-2022-31152 è una vulnerabilità ALTO (CVSS 7.5) che riguarda matrix-synapse, synapse (matrix).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 1.2%, superiore al 68.3% delle vulnerabilità.
- Correzione: aggiornare a 1.62.0, 1.62.0rc1 o successiva.
| Package | Affected versions | Patched versions |
|---|
| matrix-synapse PyPI | < 1.62.0< 1.62.0rc1
| 1.62.01.62.0rc1
|
| synapse | < 1.62.0
| 1.62.0
|
Description
Impact
The Matrix specification specifies a list of event authorization rules which must be checked when determining if an event should be accepted into a room.
In versions of Synapse up to and including v1.61, some of these rules are not correctly applied. An attacker could craft events which would be accepted by Synapse but not a spec-conformant server, potentially causing divergence in the room state between servers.
Patches
Administrators of homeservers with federation enabled are advised to upgrade to v1.62.0 or higher.
Workarounds
References
For more information
If you have any questions or comments about this advisory, e-mail us at [email protected].
NVD description
Synapse is an open-source Matrix homeserver written and maintained by the Matrix.org Foundation. The Matrix specification specifies a list of [event authorization rules](https://spec.matrix.org/v1.2/rooms/v9/#authorization-rules) which must be checked when determining if an event should be accepted into a room. In versions of Synapse up to and including version 1.61.0, some of these rules are not correctly applied. An attacker could craft events which would be accepted by Synapse but not a spec-conformant server, potentially causing divergence in the room state between servers. Administrators of homeservers with federation enabled are advised to upgrade to version 1.62.0 or higher. Federation can be disabled by setting [`federation_domain_whitelist`](https://matrix-org.github.io/synapse/latest/usage/configuration/config_documentation.html#federation_domain_whitelist) to an empty list (`[]`) as a workaround.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free