In breve
- CVE-2022-31157 è una vulnerabilità ALTO (CVSS 7.5) che riguarda packbackbooks/lti-1-3-php-library, lti 1.3 tool library (packback).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.45%, superiore al 39.5% delle vulnerabilità.
- Correzione: aggiornare a 5.0, 5.0.0 o successiva.
Description
Impact
The function used to generate random nonces was not sufficiently cryptographically complex. As a result values may be predictable and tokens may be forgable.
Patches
Users should upgrade to version 5.0 immediately
Workarounds
None.
NVD description
LTI 1.3 Tool Library is a library used for building IMS-certified LTI 1.3 tool providers in PHP. Prior to version 5.0, the function used to generate random nonces was not sufficiently cryptographically complex. Users should upgrade to version 5.0 to receive a patch. There are currently no known workarounds.
Altre vulnerabilità di packbackbooks/lti-1-3-php-library
Vedi tutto →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free