In breve
- CVE-2022-35929 è una vulnerabilità CRITICO (CVSS 9.8) che riguarda github.com/sigstore/cosign, cosign (sigstore).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.68%, superiore al 52.6% delle vulnerabilità.
- Correzione: aggiornare a 1.10.1 o successiva.
Description
cosign verify-attestation used with the --type flag will report a false positive verification when:
- There is at least one attestation with a valid signature
- There are NO attestations of the type being verified (--type defaults to "custom")
This can happen when signing with a standard keypair and with "keyless" signing with Fulcio. Users should upgrade to cosign version 1.10.1 or greater for a patch. Currently the only workaround is to upgrade.
NVD description
cosign is a container signing and verification utility. In versions prior to 1.10.1 cosign can report a false positive if any attestation exists. `cosign verify-attestation` used with the `--type` flag will report a false positive verification when there is at least one attestation with a valid signature and there are NO attestations of the type being verified (--type defaults to "custom"). This can happen when signing with a standard keypair and with "keyless" signing with Fulcio. This vulnerability can be reproduced with the `distroless.dev/static@sha256:dd7614b5a12bc4d617b223c588b4e0c833402b8f4991fb5702ea83afad1986e2` image. This image has a `vuln` attestation but not an `spdx` attestation. However, if you run `cosign verify-attestation --type=spdx` on this image, it incorrectly succeeds. This issue has been addressed in version 1.10.1 of cosign. Users are advised to upgrade. There are no known workarounds for this issue.
Altre vulnerabilità di github.com/sigstore/cosign
Vedi tutto →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free