In breve
- CVE-2022-39297 è una vulnerabilità CRITICO (CVSS 9.8) che riguarda melisplatform/melis-cms, meliscms (melistechnology).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 1.3%, superiore al 69.9% delle vulnerabilità.
- Correzione: aggiornare a 5.0.1 o successiva.
Description
Impact
Attackers can deserialize arbitrary data on affected versions of melisplatform/melis-cms, and ultimately leads to the execution of arbitrary PHP code on the system. Conducting this attack does not require authentication.
Users should immediately upgrade to melisplatform/melis-cms >= 5.0.1.
Patches
This issue was addressed by restricting allowed classes when deserializing user-controlled data.
References
For more information
If you have any questions or comments about this advisory, you can contact:
- The original reporters, by sending an email to vulnerability.research [at] sonarsource.com;
- The maintainers, by opening an issue on this repository.
NVD description
MelisCms provides a full CMS for Melis Platform, including templating system, drag'n'drop of plugins, SEO and many administration tools. Attackers can deserialize arbitrary data on affected versions of `melisplatform/melis-cms`, and ultimately leads to the execution of arbitrary PHP code on the system. Conducting this attack does not require authentication. Users should immediately upgrade to `melisplatform/melis-cms` >= 5.0.1. This issue was addressed by restricting allowed classes when deserializing user-controlled data.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free