In breve
- CVE-2022-4524 è una vulnerabilità MEDIO (CVSS 6.1) che riguarda roots/soil, soil (roots).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.59%, superiore al 48.5% delle vulnerabilità.
- Correzione: aggiornare a 4.1.0 o successiva.
| Package | Affected versions | Patched versions |
|---|
| roots/soil Packagist | < 4.1.0
| 4.1.0
|
| soil | < 4.1.0
| 4.1.0
|
Description
A vulnerability, which was classified as problematic, was found in Roots soil Plugin up to 4.1.0. Affected is the function language_attributes of the file src/Modules/CleanUpModule.php. The manipulation of the argument language leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 4.1.1 is able to address this issue. The name of the patch is 0c9151e00ab047da253e5cdbfccb204dd423269d. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-215904.
NVD description
A vulnerability, which was classified as problematic, was found in Roots soil Plugin up to 4.0.x. Affected is the function language_attributes of the file src/Modules/CleanUpModule.php. The manipulation of the argument language leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 4.1.0 is able to address this issue. The name of the patch is 0c9151e00ab047da253e5cdbfccb204dd423269d. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-215904.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free