In breve
- CVE-2023-0594 è una vulnerabilità MEDIO (CVSS 5.4) che riguarda github.com/grafana/grafana, grafana (grafana).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 9.2%, superiore al 95.3% delle vulnerabilità.
- Correzione: aggiornare a 8.5.21, 9.2.13, 9.3.8 o successiva.
| Package | Affected versions | Patched versions |
|---|
| github.com/grafana/grafana Go | ≥ 7.0.0, < 8.5.21≥ 9.0.0, < 9.2.13≥ 9.3.0, < 9.3.8
| 8.5.219.2.139.3.8
|
| grafana | ≥ 7.0.0, < 8.5.21≥ 9.2.0, < 9.2.13≥ 9.3.0, < 9.3.8
| 8.5.219.2.139.3.8
|
Description
Grafana is an open-source platform for monitoring and observability. Starting with the 7.0 branch, Grafana had a stored XSS vulnerability in the trace view visualization. The stored XSS vulnerability was possible due the value of a span's attributes/resources were not properly sanitized and this will be rendered when the span's attributes/resources are expanded. An attacker needs to have the Editor role in order to change the value of a trace view visualization to contain JavaScript. This means that vertical privilege escalation is possible, where a user with Editor role can change to a known password for a user having Admin role if the user with Admin role executes malicious JavaScript viewing a dashboard. Users may upgrade to version 8.5.21, 9.2.13 and 9.3.8 to receive a fix.
NVD description
Grafana is an open-source platform for monitoring and observability.
Starting with the 7.0 branch, Grafana had a stored XSS vulnerability in the trace view visualization.
The stored XSS vulnerability was possible due the value of a span's attributes/resources were not properly sanitized and this will be rendered when the span's attributes/resources are expanded.
An attacker needs to have the Editor role in order to change the value of a trace view visualization to contain JavaScript.
This means that vertical privilege escalation is possible, where a user with Editor role can change to a known password for a user having Admin role if the user with Admin role executes malicious JavaScript viewing a dashboard.
Users may upgrade to version 8.5.21, 9.2.13 and 9.3.8 to receive a fix.
Altre vulnerabilità di github.com/grafana/grafana
Vedi tutto →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free