In breve
- CVE-2023-22727 è una vulnerabilità CRITICO (CVSS 9.8) che riguarda cakephp/cakephp, cakephp/database, cakephp (cakephp).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.90%, superiore al 59.6% delle vulnerabilità.
- Correzione: aggiornare a 4.2.12, 4.3.11, 4.4.10 o successiva.
| Package | Affected versions | Patched versions |
|---|
| cakephp/cakephp Packagist | ≥ 4.2.0, < 4.2.12≥ 4.3.0, < 4.3.11≥ 4.4.0, < 4.4.10
| 4.2.124.3.114.4.10
|
| cakephp/database Packagist | ≥ 4.2.0, < 4.2.12≥ 4.3.0, < 4.3.11≥ 4.4.0, < 4.4.10
| 4.2.124.3.114.4.10
|
| cakephp | ≥ 4.2.0, < 4.2.12≥ 4.3.0, < 4.3.11≥ 4.4.0, < 4.4.10
| 4.2.124.3.114.4.10
|
Description
Impact
The Cake\Database\Query::limit() and Cake\Database\Query::offset() methods are vulnerable to SQL injection if passed un-sanitized user request data.
Patches
This issue has been fixed in 4.2.12, 4.3.11, 4.4.10
Workarounds
Using CakePHP's Pagination library will mitigate this issue, as will validating or casting parameters to these methods.
References
https://bakery.cakephp.org/2023/01/06/cakephp_4211_4311_4410_released.html
NVD description
CakePHP is a development framework for PHP web apps. In affected versions the `Cake\Database\Query::limit()` and `Cake\Database\Query::offset()` methods are vulnerable to SQL injection if passed un-sanitized user request data. This issue has been fixed in 4.2.12, 4.3.11, 4.4.10. Users are advised to upgrade. Users unable to upgrade may mitigate this issue by using CakePHP's Pagination library. Manually validating or casting parameters to these methods will also mitigate the issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free