| Package | Affected versions | Patched versions |
|---|---|---|
| silverstripe/graphql | ≥ 4.1.1, < 4.1.2≥ 4.2.2, < 4.2.3 | 4.1.24.2.3 |
| graphql | = 4.1.1= 4.2.2 |
An attacker could use a specially crafted graphql query to execute a Distributed Denial of Service attack (DDOS attack) against a website. This mostly affects websites with publicly exposed and particularly large/complex graphql schemas.
If your Silverstripe CMS project does not expose a public facing graphql schema, a user account is required to trigger the DDOS attack. If your site is hosted behind a content delivery network (CDN), such as Imperva or CloudFlare, this will likely further mitigate the risk.
Upgrade to silverstripe/graphql 4.2.3 or 4.1.2 or above to remedy the vulnerability.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free