In breve
- CVE-2023-37379 è una vulnerabilità ALTO (CVSS 8.1) che riguarda apache-airflow, airflow (apache).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 2.0%, superiore al 80.3% delle vulnerabilità.
- Correzione: aggiornare a 2.7.0, 2.7.0b1 o successiva.
| Package | Affected versions | Patched versions |
|---|
| apache-airflow PyPI | < 2.7.0< 2.7.0b1
| 2.7.02.7.0b1
|
| airflow | < 2.7.0
| 2.7.0
|
Description
Apache Airflow, in versions prior to 2.7.0, contains a security vulnerability that can be exploited by an authenticated user possessing Connection edit privileges. This vulnerability allows the user to access connection information and exploit the test connection feature by sending many requests, leading to a denial of service (DoS) condition on the server. Furthermore, malicious actors can leverage this vulnerability to establish harmful connections with the server.
Users of Apache Airflow are strongly advised to upgrade to version 2.7.0 or newer to mitigate the risk associated with this vulnerability. Additionally, administrators are encouraged to review and adjust user permissions to restrict access to sensitive functionalities, reducing the attack surface.
NVD description
Apache Airflow, in versions prior to 2.7.0, contains a security vulnerability that can be exploited by an authenticated user possessing Connection edit privileges. This vulnerability allows the user to access connection information and exploit the test connection feature by sending many requests, leading to a denial of service (DoS) condition on the server. Furthermore, malicious actors can leverage this vulnerability to establish harmful connections with the server.
Users of Apache Airflow are strongly advised to upgrade to version 2.7.0 or newer to mitigate the risk associated with this vulnerability. Additionally, administrators are encouraged to review and adjust user permissions to restrict access to sensitive functionalities, reducing the attack surface.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free