| Package | Affected versions | Patched versions |
|---|---|---|
| discourse | = 1.1.0= 1.2.0= 1.3.0= 1.4.0= 1.5.0= 1.6.0= 1.7.0= 1.8.0= 1.9.0= 2.0.0= 2.1.0= 2.2.0= 2.3.0= 2.4.0= 2.5.0= 2.6.0= 2.7.0= 2.8.0= 2.9.0= 3.0.0= 3.1.0< 3.1.1 | 3.1.1 |
Discourse is an open-source discussion platform. Prior to version 3.1.1 of the `stable` branch and version 3.2.0.beta1 of the `beta` and `tests-passed` branches, a malicious user could add a 2FA or security key with a carefully crafted name to their account and cause a denial of service for other users. The issue is patched in version 3.1.1 of the `stable` branch and version 3.2.0.beta1 of the `beta` and `tests-passed` branches. There are no known workarounds.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free