In breve
- CVE-2023-47248 è una vulnerabilità CRITICO (CVSS 9.8) che riguarda pyarrow, pyarrow (apache).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 14.5%, superiore al 96.6% delle vulnerabilità.
- Correzione: aggiornare a 14.0.1 o successiva.
| Package | Affected versions | Patched versions |
|---|
| pyarrow PyPI | ≥ 0.14.0, < 14.0.1
| 14.0.1
|
| pyarrow | ≥ 0.14.0, ≤ 14.0.0
| No fix yet |
Description
Deserialization of untrusted data in IPC and Parquet readers in PyArrow versions 0.14.0 to 14.0.0 allows arbitrary code execution. An application is vulnerable if it reads Arrow IPC, Feather or Parquet data from untrusted sources (for example user-supplied input files).
This vulnerability only affects PyArrow, not other Apache Arrow implementations or bindings.
It is recommended that users of PyArrow upgrade to 14.0.1. Similarly, it is recommended that downstream libraries upgrade their dependency requirements to PyArrow 14.0.1 or later. PyPI packages are already available, and we hope that conda-forge packages will be available soon.
If it is not possible to upgrade, maintainers provide a separate package pyarrow-hotfix that disables the vulnerability on older PyArrow versions. See https://pypi.org/project/pyarrow-hotfix/ for instructions.
NVD description
Deserialization of untrusted data in IPC and Parquet readers in PyArrow versions 0.14.0 to 14.0.0 allows arbitrary code execution. An application is vulnerable if it reads Arrow IPC, Feather or Parquet data from untrusted sources (for example user-supplied input files).
This vulnerability only affects PyArrow, not other Apache Arrow implementations or bindings.
It is recommended that users of PyArrow upgrade to 14.0.1. Similarly, it is recommended that downstream libraries upgrade their dependency requirements to PyArrow 14.0.1 or later. PyPI packages are already available, and we hope that conda-forge packages will be available soon.
If it is not possible to upgrade, we provide a separate package `pyarrow-hotfix` that disables the vulnerability on older PyArrow versions. See https://pypi.org/project/pyarrow-hotfix/ for instructions.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free