In breve
- CVE-2023-47265 è una vulnerabilità MEDIO (CVSS 5.4) che riguarda apache-airflow, airflow (apache).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 1.3%, superiore al 71.4% delle vulnerabilità.
- Correzione: aggiornare a 2.8.0b1 o successiva.
| Package | Affected versions | Patched versions |
|---|
| apache-airflow PyPI | ≥ 2.6.0, < 2.8.0b1
| 2.8.0b1
|
| airflow | ≥ 2.6.0, ≤ 2.7.3
| No fix yet |
Description
Apache Airflow, versions 2.6.0 through 2.7.3 has a stored XSS vulnerability that allows a DAG author to add an unbounded and not-sanitized javascript in the parameter description field of the DAG. This Javascript can be executed on the client side of any of the user who looks at the tasks in the browser sandbox. While this issue does not allow to exit the browser sandbox or manipulation of the server-side data - more than the DAG author already has, it allows to modify what the user looking at the DAG details sees in the browser - which opens up all kinds of possibilities of misleading other users.
Users of Apache Airflow are recommended to upgrade to version 2.8.0 or newer to mitigate the risk associated with this vulnerability
NVD description
Apache Airflow, versions 2.6.0 through 2.7.3 has a stored XSS vulnerability that allows a DAG author to add an unbounded and not-sanitized javascript in the parameter description field of the DAG. This Javascript can be executed on the client side of any of the user who looks at the tasks in the browser sandbox. While this issue does not allow to exit the browser sandbox or manipulation of the server-side data - more than the DAG author already has, it allows to modify what the user looking at the DAG details sees in the browser - which opens up all kinds of possibilities of misleading other users.
Users of Apache Airflow are recommended to upgrade to version 2.8.0 or newer to mitigate the risk associated with this vulnerability
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free