In breve
- CVE-2023-48217 è una vulnerabilità ALTO (CVSS 8.8) che riguarda statamic/cms, statamic (statamic).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 1.1%, superiore al 65.8% delle vulnerabilità.
- Correzione: aggiornare a 4.34.0, 3.4.14 o successiva.
| Package | Affected versions | Patched versions |
|---|
| statamic/cms Packagist | ≥ 4.0.0, < 4.34.0< 3.4.14
| 4.34.03.4.14
|
| statamic | ≥ 4.0.0, < 4.34.0< 3.4.14
| 4.34.03.4.14
|
Description
Impact
Similar to another advisory, certain additional PHP files crafted to look like images may be uploaded regardless of mime type validation rules. This affects front-end forms using the "Forms" feature, and asset upload fields in the control panel.
Patches
It has been patched in 3.4.14 and 4.34.0.
NVD description
Statamic is a flat-first, Laravel + Git powered CMS designed for building websites. In affected versions certain additional PHP files crafted to look like images may be uploaded regardless of mime type validation rules. This affects front-end forms using the "Forms" feature, and asset upload fields in the control panel. Malicious users could leverage this vulnerability to upload and execute code. This issue has been patched in versions 3.4.14 and 4.34.0. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free