In breve
- CVE-2023-49736 è una vulnerabilità ALTO (CVSS 8.8) che riguarda apache-superset, superset (apache).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 1.2%, superiore al 67.9% delle vulnerabilità.
- Correzione: aggiornare a 3.0.2, 2.1.3, 2.1.2 o successiva.
| Package | Affected versions | Patched versions |
|---|
| apache-superset PyPI | ≥ 3.0.0, < 3.0.2< 2.1.3
| 3.0.22.1.3
|
| superset | ≥ 3.0.0, < 3.0.2< 2.1.2
| 3.0.22.1.2
|
Description
A where_in JINJA macro allows users to specify a quote, which combined with a carefully crafted statement would allow for SQL injection in Apache Superset.This issue affects Apache Superset: before 2.1.3, from 3.0.0 before 3.0.2.
Users are recommended to upgrade to version 2.1.3 or 3.0.2, which fixes the issue.
NVD description
A where_in JINJA macro allows users to specify a quote, which combined with a carefully crafted statement would allow for SQL injection in Apache Superset.This issue affects Apache Superset: before 2.1.2, from 3.0.0 before 3.0.2.
Users are recommended to upgrade to version 3.0.2, which fixes the issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free