In breve
- CVE-2023-51699 è una vulnerabilità MEDIO (CVSS 6.0) che riguarda github.com/fluid-cloudnative/fluid, fluid (linuxfoundation).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.61%, superiore al 49.3% delle vulnerabilità.
- Correzione: aggiornare a 0.9.3 o successiva.
Description
Impact
OS command injection vulnerability within the Fluid project's JuicefsRuntime can potentially allow an authenticated user, who has the authority to create or update the K8s CRD Dataset/JuicefsRuntime, to execute arbitrary OS commands within the juicefs related containers. This could lead to unauthorized access, modification or deletion of data.
Patches
For users who're using version < 0.9.3 with JuicefsRuntime, upgrade to v0.9.3.
References
Are there any links users can visit to find out more?
Credits
Special thanks to the discovers of this issue:
Xiaozheng Zhang [email protected]
NVD description
Fluid is an open source Kubernetes-native Distributed Dataset Orchestrator and Accelerator for data-intensive applications. An OS command injection vulnerability within the Fluid project's JuicefsRuntime can potentially allow an authenticated user, who has the authority to create or update the K8s CRD Dataset/JuicefsRuntime, to execute arbitrary OS commands within the juicefs related containers. This could lead to unauthorized access, modification or deletion of data. Users who're using versions < 0.9.3 with JuicefsRuntime should upgrade to v0.9.3.
Altre vulnerabilità di github.com/fluid-cloudnative/fluid
Vedi tutto →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free