| Package | Affected versions | Patched versions |
|---|---|---|
| org.apache.camel:camel-sql | ≥ 3.0.0, < 3.21.4≥ 3.22.0, < 3.22.1≥ 4.0.0, < 4.0.4≥ 4.1.0, < 4.4.0 | 3.21.43.22.14.0.44.4.0 |
| camel | = 3.22.0≥ 3.0.0, < 3.21.4≥ 4.0.0, < 4.0.4≥ 4.1.0, < 4.4.0 | 3.21.44.0.44.4.0 |
Deserialization of Untrusted Data vulnerability in Apache Camel SQL Component. This issue affects Apache Camel: from 3.0.0 before 3.21.4, from 3.22.0 before 3.22.1, from 4.0.0 before 4.0.4, from 4.1.0 before 4.4.0.
Users are recommended to upgrade to version 4.4.0, which fixes the issue. If users are on the 4.0.x LTS releases stream, then they are suggested to upgrade to 4.0.4. If users are on 3.x, they are suggested to move to 3.21.4 or 3.22.1
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free