In breve
- CVE-2024-23114 è una vulnerabilità CRITICO (CVSS 9.8) che riguarda org.apache.camel:camel-cassandraql, camel (apache).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 1.3%, superiore al 69.9% delle vulnerabilità.
- Correzione: aggiornare a 3.21.4, 3.22.1, 4.0.4, 4.4.0 o successiva.
| Package | Affected versions | Patched versions |
|---|
| org.apache.camel:camel-cassandraql Maven | ≥ 3.0.0, < 3.21.4≥ 3.22.0, < 3.22.1≥ 4.0.0, < 4.0.4≥ 4.1.0, < 4.4.0
| 3.21.43.22.14.0.44.4.0
|
| camel | = 3.22.0≥ 3.0.0, < 3.21.4≥ 4.0.0, < 4.0.4≥ 4.1.0, < 4.4.0
| 3.21.44.0.44.4.0
|
Description
Deserialization of Untrusted Data vulnerability in Apache Camel CassandraQL Component AggregationRepository which is vulnerable to unsafe deserialization. Under specific conditions it is possible to deserialize malicious payload.This issue affects Apache Camel: from 3.0.0 before 3.21.4, from 3.22.0 before 3.22.1, from 4.0.0 before 4.0.4, from 4.1.0 before 4.4.0.
Users are recommended to upgrade to version 4.4.0, which fixes the issue. If users are on the 4.0.x LTS releases stream, then they are suggested to upgrade to 4.0.4. If users are on 3.x, they are suggested to move to 3.21.4 or 3.22.1
NVD description
Deserialization of Untrusted Data vulnerability in Apache Camel CassandraQL Component AggregationRepository which is vulnerable to unsafe deserialization. Under specific conditions it is possible to deserialize malicious payload.This issue affects Apache Camel: from 3.0.0 before 3.21.4, from 3.22.0 before 3.22.1, from 4.0.0 before 4.0.4, from 4.1.0 before 4.4.0.
Users are recommended to upgrade to version 4.4.0, which fixes the issue. If users are on the 4.0.x LTS releases stream, then they are suggested to upgrade to 4.0.4. If users are on 3.x, they are suggested to move to 3.21.4 or 3.22.1
Altre vulnerabilità di org.apache.camel:camel-cassandraql
Vedi tutto →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free