In breve
- CVE-2024-26140 è una vulnerabilità MEDIO (CVSS 6.1) che riguarda com.yetanalytics:lrs, lrs (yetanalytics), sql lrs (yetanalytics).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.45%, superiore al 39.1% delle vulnerabilità.
- Correzione: aggiornare a 1.2.17, 0.7.5 o successiva.
Description
Impact
A maliciously crafted xAPI statement could be used to perform script or other tag injection in the LRS Statement Browser.
Patches
The problem is patched in version 1.2.17 of the LRS library and version 0.7.5 of SQL LRS.
Workarounds
No workarounds exist, we recommend upgrading to version 1.2.17 of the library or version 0.7.5 of SQL LRS immediately.
References
NVD description
com.yetanalytics/lrs is the Yet Analytics Core LRS Library. Prior to version 1.2.17 of the LRS library and version 0.7.5 of SQL LRS, a maliciously crafted xAPI statement could be used to perform script or other tag injection in the LRS Statement Browser. The problem is patched in version 1.2.17 of the LRS library and version 0.7.5 of SQL LRS. No known workarounds exist.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free