In breve
- CVE-2024-27439 è una vulnerabilità MEDIO (CVSS 6.5) che riguarda org.apache.wicket:wicket, wicket (apache).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.68%, superiore al 52.4% delle vulnerabilità.
- Correzione: aggiornare a 10.0.0, 9.17.0 o successiva.
| Package | Affected versions | Patched versions |
|---|
| org.apache.wicket:wicket Maven | ≥ 10.0.0-M1, < 10.0.0≥ 9.1.0, < 9.17.0
| 10.0.09.17.0
|
| wicket | = 10.0.0≥ 9.1.0, < 9.17.0
| 9.17.0
|
Description
An error in the evaluation of the fetch metadata headers could allow a bypass of the CSRF protection in Apache Wicket.
This issue affects Apache Wicket: from 9.1.0 through 9.16.0, and the milestone releases for the 10.0 series.
Apache Wicket 8.x does not support CSRF protection via the fetch metadata headers and as such is not affected.
Users are recommended to upgrade to version 9.17.0 or 10.0.0, which fixes the issue.
NVD description
An error in the evaluation of the fetch metadata headers could allow a bypass of the CSRF protection in Apache Wicket.
This issue affects Apache Wicket: from 9.1.0 through 9.16.0, and the milestone releases for the 10.0 series.
Apache Wicket 8.x does not support CSRF protection via the fetch metadata headers and as such is not affected.
Users are recommended to upgrade to version 9.17.0 or 10.0.0, which fixes the issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free