In breve
- CVE-2024-27926 è una vulnerabilità MEDIO (CVSS 6.1) che riguarda rsshub (rsshub), rsshub.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.52%, superiore al 44.4% delle vulnerabilità.
- Correzione: aggiornare a 1.0.0-master.d8ca915 o successiva.
| Package | Affected versions | Patched versions |
|---|
| rsshub | ≥ 1.0.0-master.cbbd829, < 1.0.0-master.d8ca915
| 1.0.0-master.d8ca915
|
| rsshub npm | ≥ 1.0.0-master.cbbd829, < 1.0.0-master.d8ca915
| 1.0.0-master.d8ca915
|
Description
Impact
When the specially crafted image is supplied to the internal media proxy, it proxies the image without handling XSS vulnerabilities, allowing for the execution of arbitrary JavaScript code.
Users who access the deliberately constructed URL are affected.
Patches
This vulnerability was fixed in version https://github.com/DIYgod/RSSHub/commit/4d3e5d79c1c17837e931b4cd253d2013b487aa87. Please upgrade to this or a later version.
Workarounds
No.
NVD description
RSSHub is an open source RSS feed generator. Starting in version 1.0.0-master.cbbd829 and prior to version 1.0.0-master.d8ca915, ahen the specially crafted image is supplied to the internal media proxy, it proxies the image without handling XSS vulnerabilities, allowing for the execution of arbitrary JavaScript code. Users who access the deliberately constructed URL are affected. This vulnerability was fixed in version 1.0.0-master.d8ca915. No known workarounds are available.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free