In breve
- CVE-2024-2928 è una vulnerabilità ALTO (CVSS 7.5) che riguarda mlflow, mlflow (lfprojects).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 21.8%, superiore al 97.6% delle vulnerabilità.
- Correzione: aggiornare a 2.11.3 o successiva.
| Package | Affected versions | Patched versions |
|---|
| mlflow PyPI | < 2.11.3
| 2.11.3
|
| mlflow | < 2.11.3
| 2.11.3
|
Description
A Local File Inclusion (LFI) vulnerability was identified in mlflow/mlflow, specifically in version 2.9.2, which was fixed in version 2.11.3. This vulnerability arises from the application's failure to properly validate URI fragments for directory traversal sequences such as '../'. An attacker can exploit this flaw by manipulating the fragment part of the URI to read arbitrary files on the local file system, including sensitive files like '/etc/passwd'. The vulnerability is a bypass to a previous patch that only addressed similar manipulation within the URI's query string, highlighting the need for comprehensive validation of all parts of a URI to prevent LFI attacks.
NVD description
A Local File Inclusion (LFI) vulnerability was identified in mlflow/mlflow, specifically in version 2.9.2, which was fixed in version 2.11.3. This vulnerability arises from the application's failure to properly validate URI fragments for directory traversal sequences such as '../'. An attacker can exploit this flaw by manipulating the fragment part of the URI to read arbitrary files on the local file system, including sensitive files like '/etc/passwd'. The vulnerability is a bypass to a previous patch that only addressed similar manipulation within the URI's query string, highlighting the need for comprehensive validation of all parts of a URI to prevent LFI attacks.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free