In breve
- CVE-2024-29733 è una vulnerabilità BASSO (CVSS 2.7) che riguarda apache-airflow-providers-ftp, apache-airflow-providers-ftp (apache).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.63%, superiore al 50.4% delle vulnerabilità.
- Correzione: aggiornare a 3.7.0 o successiva.
Description
Improper Certificate Validation vulnerability in Apache Airflow FTP Provider.
The FTP hook lacks complete certificate validation in FTP_TLS connections, which can potentially be leveraged. Implementing proper certificate validation by passing context=ssl.create_default_context() during FTP_TLS instantiation is used as mitigation to validate the certificates properly.
This issue affects Apache Airflow FTP Provider: before 3.7.0.
Users are recommended to upgrade to version 3.7.0, which fixes the issue.
NVD description
Improper Certificate Validation vulnerability in Apache Airflow FTP Provider.
The FTP hook lacks complete certificate validation in FTP_TLS connections, which can potentially be leveraged. Implementing proper certificate validation by passing context=ssl.create_default_context() during FTP_TLS instantiation is used as mitigation to validate the certificates properly.
This issue affects Apache Airflow FTP Provider: before 3.7.0.
Users are recommended to upgrade to version 3.7.0, which fixes the issue.
Altre vulnerabilità di apache-airflow-providers-ftp
Vedi tutto →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free