In breve
- CVE-2024-29904 è una vulnerabilità ALTO (CVSS 7.5) che riguarda codeigniter4/framework, codeigniter (codeigniter).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.77%, superiore al 55.7% delle vulnerabilità.
- Correzione: aggiornare a 4.4.7 o successiva.
Description
Impact
A vulnerability was found in the Language class that allowed DoS attacks. This vulnerability can be exploited by an attacker to consume a large amount of memory on the server.
Patches
Upgrade to v4.4.7 or later. See upgrading guide.
Workarounds
- Disabling Auto Routing prevents a known attack vector in the framework.
- Do not pass invalid values to the
lang() function or Language class.
References
NVD description
CodeIgniter is a PHP full-stack web framework A vulnerability was found in the Language class that allowed DoS attacks. This vulnerability can be exploited by an attacker to consume a large amount of memory on the server. Upgrade to v4.4.7 or later.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free