In breve
- CVE-2024-40761 è una vulnerabilità MEDIO (CVSS 5.3) che riguarda github.com/apache/incubator-answer, answer (apache).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.75%, superiore al 54.9% delle vulnerabilità.
- Correzione: aggiornare a 1.4.0 o successiva.
Description
Inadequate Encryption Strength vulnerability in Apache Answer.
This issue affects Apache Answer: through 1.3.5.
Using the MD5 value of a user's email to access Gravatar is insecure and can lead to the leakage of user email. The official recommendation is to use SHA256 instead.
Users are recommended to upgrade to version 1.4.0, which fixes the issue.
NVD description
Inadequate Encryption Strength vulnerability in Apache Answer.
This issue affects Apache Answer: through 1.3.5.
Using the MD5 value of a user's email to access Gravatar is insecure and can lead to the leakage of user email. The official recommendation is to use SHA256 instead.
Users are recommended to upgrade to version 1.4.0, which fixes the issue.
Altre vulnerabilità di github.com/apache/incubator-answer
Vedi tutto →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free