In breve
- CVE-2024-41675 è una vulnerabilità MEDIO (CVSS 6.1) che riguarda ckan, ckan (okfn).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.40%, superiore al 34.6% delle vulnerabilità.
- Correzione: aggiornare a 2.10.5 o successiva.
| Package | Affected versions | Patched versions |
|---|
| ckan PyPI | ≥ 2.7.0, < 2.10.5
| 2.10.5
|
| ckan | ≥ 2.7.0, < 2.10.5
| 2.10.5
|
Description
The Datatables view plugin did not properly escape record data coming from the DataStore, leading to a potential XSS vector.
Impact
Sites running CKAN >= 2.7.0 with the datatables_view plugin activated. This is a plugin included in CKAN core, that not activated by default but it is widely used to preview tabular data.
Patches
This vulnerability has been fixed in CKAN 2.10.5 and 2.11.0
Workarounds
Prevent importing of tabular files to the DataStore via DataPusher, XLoader,etc, at least those published from untrusted sources.
NVD description
CKAN is an open-source data management system for powering data hubs and data portals. The Datatables view plugin did not properly escape record data coming from the DataStore, leading to a potential XSS vector. Sites running CKAN >= 2.7.0 with the datatables_view plugin activated. This is a plugin included in CKAN core, that not activated by default but it is widely used to preview tabular data. This vulnerability has been fixed in CKAN 2.10.5 and 2.11.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free