In breve
- CVE-2024-41962 è una vulnerabilità MEDIO (CVSS 6.3) che riguarda bostr (yonle), bostr.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.30%, superiore al 22.6% delle vulnerabilità.
- Correzione: aggiornare a 3.0.10 o successiva.
| Package | Affected versions | Patched versions |
|---|
| bostr | < 3.0.10
| 3.0.10
|
| bostr npm | < 3.0.10
| 3.0.10
|
Description
Even with authorized_keys is filled with allowed pubkeys, If noscraper is enabled, It will allow anyone to use bouncer even it's pubkey is not in authorized_keys.
Impact
Patches
Available on version 3.0.10
Workarounds
Disable noscraper if you have authorized_keys being set in config
References
This line of code is the cause.
NVD description
Bostr is an nostr relay aggregator proxy that acts like a regular nostr relay. bostr let everyone in even having authorized_keys being set when noscraper is set to true. This vulnerability is fixed in 3.0.10.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free