| Package | Affected versions | Patched versions |
|---|---|---|
| actions/artifact | ≥ 2.0.0, < 2.1.7 | 2.1.7 |
| @actions/artifact | ≥ 2.0.0, < 2.1.2 | 2.1.2 |
Versions of actions/artifact before 2.1.7 are vulnerable to arbitrary file write when using downloadArtifactInternal, downloadArtifactPublic, or streamExtractExternal for extracting a specifically crafted artifact that contains path traversal filenames.
Upgrade to version 2.1.7 or higher.
CVE-2024-42471
Justin Taft from Google
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free