| Package | Affected versions | Patched versions |
|---|---|---|
| asterisk | ≥ 20.0.0, < 20.9.3≥ 21.0.0, ≤ 21.4.3< 18.24.3 | 20.9.318.24.3 |
| certified asterisk | = 18.9= 20.7< 18.9 | 18.9 |
Asterisk is an open-source private branch exchange (PBX). Prior to versions 18.24.3, 20.9.3, and 21.4.3 of Asterisk and versions 18.9-cert12 and 20.7-cert2 of certified-asterisk, if Asterisk attempts to send a SIP request to a URI whose host portion starts with `.1` or `[.1]`, and res_resolver_unbound is loaded, Asterisk will crash with a SEGV. To receive a patch, users should upgrade to one of the following versions: 18.24.3, 20.9.3, 21.4.3, certified-18.9-cert12, certified-20.7-cert2. Two workarounds are available. Disable res_resolver_unbound by setting `noload = res_resolver_unbound.so` in modules.conf, or set `rewrite_contact = yes` on all PJSIP endpoints. NOTE: This may not be appropriate for all Asterisk configurations.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free