In breve
- CVE-2024-45401 è una vulnerabilità ALTO (CVSS 7.1) che riguarda github.com/stripe/stripe-cli, stripe cli (stripe).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.21%, superiore al 10.9% delle vulnerabilità.
- Correzione: aggiornare a 1.21.3 o successiva.
Description
Impact
A vulnerability exists in stripe-cli versions 1.11.1 and higher where a plugin package containing a manifest with a malformed plugin shortname installed using the --archive-url or --archive-path flags can overwrite arbitrary files.
The update addresses the path traversal vulnerability by removing the ability to install plugins from an archive URL or path.
There has been no evidence of exploitation of this vulnerability.
Recommendation
Upgrade to stripe-cli v1.21.3.
Acknowledgements
Thank you to 0xacb and bordiez for reporting this vulnerability.
For more information
Email us at [email protected]
NVD description
stripe-cli is a command-line tool for the payment processor Stripe. A vulnerability exists in stripe-cli starting in version 1.11.1 and prior to version 1.21.3 where a plugin package containing a manifest with a malformed plugin shortname installed using the --archive-url or --archive-path flags can overwrite arbitrary files. The update in version 1.21.3 addresses the path traversal vulnerability by removing the ability to install plugins from an archive URL or path. There has been no evidence of exploitation of this vulnerability.
Altre vulnerabilità di github.com/stripe/stripe-cli
Vedi tutto →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free