In breve
- CVE-2024-45590 è una vulnerabilità ALTO (CVSS 7.5) che riguarda body-parser (openjsf), body-parser.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.82%, superiore al 57.4% delle vulnerabilità.
- Correzione: aggiornare a 1.20.3 o successiva.
Description
Impact
body-parser <1.20.3 is vulnerable to denial of service when url encoding is enabled. A malicious actor using a specially crafted payload could flood the server with a large number of requests, resulting in denial of service.
Patches
this issue is patched in 1.20.3
References
NVD description
body-parser is Node.js body parsing middleware. body-parser <1.20.3 is vulnerable to denial of service when url encoding is enabled. A malicious actor using a specially crafted payload could flood the server with a large number of requests, resulting in denial of service. This issue is patched in 1.20.3.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free