In breve
- CVE-2024-47053 è una vulnerabilità ALTO (CVSS 7.7) che riguarda mautic/core, mautic (acquia).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.74%, superiore al 54.5% delle vulnerabilità.
- Correzione: aggiornare a 5.2.3 o successiva.
| Package | Affected versions | Patched versions |
|---|
| mautic/core Packagist | ≥ 1.0.1, < 5.2.3
| 5.2.3
|
| mautic | ≥ 1.0.1, < 5.2.3
| 5.2.3
|
Description
Summary
This advisory addresses an authorization vulnerability in Mautic's HTTP Basic Authentication implementation. This flaw could allow unauthorized access to sensitive report data.
- Improper Authorization: An authorization flaw exists in Mautic's API Authorization implementation. Any authenticated user, regardless of assigned roles or permissions, can access all reports and their associated data via the API. This bypasses the intended access controls governed by the "Reporting Permissions > View Own" and "Reporting Permissions > View Others" permissions, which should restrict access to non-System Reports.
Mitigation
Please update to Mautic 5.2.3 or later
Workarounds
Disable the API in Mautic. See documentation.
References
https://cwe.mitre.org/data/definitions/285.html
https://docs.mautic.org/en/5.2/configuration/settings.html#api-settings
If you have any questions or comments about this advisory:
Email us at [email protected]
NVD description
This advisory addresses an authorization vulnerability in Mautic's HTTP Basic Authentication implementation. This flaw could allow unauthorized access to sensitive report data.
* Improper Authorization: An authorization flaw exists in Mautic's API Authorization implementation. Any authenticated user, regardless of assigned roles or permissions, can access all reports and their associated data via the API. This bypasses the intended access controls governed by the "Reporting Permissions > View Own" and "Reporting Permissions > View Others" permissions, which should restrict access to non-System Reports.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free