In breve
- CVE-2024-47178 è una vulnerabilità MEDIO (CVSS 5.3) che riguarda basic-auth-connect (expressjs), basic-auth-connect.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.52%, superiore al 44.4% delle vulnerabilità.
- Correzione: aggiornare a 1.1.0 o successiva.
Description
Impact
basic-auth-connect <1.1.0 uses a timing-unsafe equality comparison that can leak timing information
Patches
this issue has been fixed in basic-auth-connect 1.1.0
References
NVD description
basic-auth-connect is Connect's Basic Auth middleware in its own module. basic-auth-connect < 1.1.0 uses a timing-unsafe equality comparison that can leak timing information. This issue has been fixed in basic-auth-connect 1.1.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free